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1. Introduction 
This manual describes the installation of Vircom ModusGate version 4 on a Microsoft Windows 
2003 Small Business Server. The installation of the SBS server and configuration of Exchange 
are not the subject of this manual, and therefore not included. 

 

1.1. About ModusGate 
ModusGate is a powerful Email protection program offering Email servers and users security 
against unsolicited commercial email (spam), virus, phishing attacks and other threats. 
 
Two versions of ModusGate are available:  

• ModusGate AS with anti-spam  
• ModusGate ASV with anti-spam and anti-virus: either Norman or MacAfee 

 
In this manual we describe installation of ModusGate ASV-N version 4. 
If you install the AS version, all listed options might not be available in your software version. 
 

1.2. Prerequisites 
 
In this manual we assume: 

• Small Business Server 2003 server is already installed and operational 

• Active Directory is up and running, managing Exchange users 

• Exchange has been configured using standard SBS software and is fully operational 

• Outlook is configured on workstations to send and collect emails through Exchange. 

• The SBS server RAM is at least 1 GB. If the server runs more than SBS 2003 and 
Exchange programs, 1.5 GB or more is recommended. See the ModusGate system 
requirements document at the bottom of the following knowledge base article: 

Info: Hardware & OS Specifications 
http://www.vircom.com/kbase/default.asp?id=1270&SID=&Lang=1 
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2. Installation Requirements 
 
Before installing ModusGate, a few items needs to be set up and checked. 
For instance, a ModusGate account needs to be created in Active Directory, the SBS server 
must have a unique static I.P. address, and a primary DNS suffix. 
 

2.1. Unique static I.P. address 
 
Click: Start > Control Panel > Network Connections > Server local area connection > 
Support > Address type. A static address displays: ‘manually configured’, and the configured 
IP address is displayed on the next line. 
 

2.2. DNS suffix 
 
To check the primary DNS-suffix, right click on My Computer > Properties > Computer 

Name tab. This window displays the SBS 2003 server full computer name and domain name. 
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2.3. ModusGate account creation in Active Directory 
 
In order to verify incoming mail recipients Email addresses, ModusGate needs an account to 
check Active Directory/Exchange users. An actual mailbox is not necessary, only an account 
with read-only permission on active Directory. 
 
Before beginning the ModusGate installation, this account must be created. 
 
Click Start > All Programs > Microsoft Exchange > Active Directory Users and 
Computers. 
 
Create a new user, and name it ‘modusgate’. Enter a password and select the options User 
cannot change password and Password never expires. 
 

               
 
                Figure 1: ModusGate account creation Figure 2: ModusGate account password 

 
Click Next, and disable Create Exchange mailbox. An Exchange mailbox is not necessary for 
this account. 

                  
 
 Figure 3: ModusGate account without mailbox Figure 4: ModusGate account read only permission 

 
 
Click Start > Active Directory Users and Computers. In the menu click View > Advanced 
features. Right click on the domain name and select Properties. Select the Security tab, 
click Add and add the new ‘modugate’ account you have just created. Assign it the Read 
permission only. 
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3. ModusGate Installation 
 

3.1. ModusGate software installation 
 
The latest versions of ModusGate can be downloaded from the Vircom download web site: 
https://secure.vircom.com/Customer_Resources/Login.asp. Once the file has been downloaded, double 
click on the MGATExxxxxx.EXE file to start installation. (e.g.: MGATE568ASVN.EXE) 
 
Make sure you are installing the latest version of the ModusGate software. The version is 
displayed in the first installation window. Click Next to go on with installing. 

 

 
 

Figure 5: ModusGate software version 

 
 
Agree with the license. 

 

 
 

Figure 6: ModusGate license agreement 
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You need a valid license key. Vircom issues either evaluation or standard license keys. Enter 
your key, click Validate and click Next. In the example, we have replaced your license key 
with XXXX-XXXX-XXXX-XXXX-XXXX-XXXX. 

 

 
 

Figure 7: ModusGate license key 

 
 
You can select which components to install. For a standard ModusGate installation in SBS, 
select both the Server and Administration Console and the Web Component. 

 

 
 

Figure 8: ModusGate components 
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You can select where the mail component software (the ModusGate server software) and the 
Web component (for remote management) will be installed. By default all components are 
installed in the \Program Files\Vircom\ folder. 

 

 
 

Figure 9: ModusGate installation path 

 
 
If received emails can neither be delivered nor be returned to sender, they can be routed to 
the postmaster who will decide what to do with them. Therefore you can enter a postmaster 
email address or an email address of the person who will handle these undelivered emails. 

 

 
 

Figure 10: Postmaster address 
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ModusGate makes use of Microsoft Internet Information Server: IIS. To allow automatic 
configuration of these ModusGate settings, select Automatic configuration. 

 

 
 

Figure 11: Automatic configuration 

 
By default the monitoring service stores traffic statistics in a PostgreSQL database. Unless you 
have a fully operational MS-SQL 2000 or 2005 server you can use, select PostgreSQL 
installation. 
 
WARNING: PostgreSQL installation will fail if installed from a remote desktop connection 
(Terminal services). If you need to install PostgreSQL, run the ModusGate installation either 
from the local server console or using remote access like free VNC. (http://ww.realvnc.com) 
 

 

 
 

Figure 12: PostgreSQL installation 

 
Two accounts are automatically created for PostgreSQL: the service account and the 
administrator account. Both accounts will be protected by passwords. They need to be entered 
here. The location of the PostgreSQL database can be selected as well. Keep the current path 
unless you have another disk drive to install it on for better performance. If you only need to 
have the PostgreSQL database moved to another drive, not the PostgreSQL program, it can be 
moved at a later time. See the following Vircom knowledge base article: 

How-To: Move PostgreSQL from One Drive to Another 
http://www.vircom.com/kbase/default.asp?id=1512&SID=&Lang=1 
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Leave this option enabled to allow IIS service restart. If you disable this option, the server will 
have to be restarted at the end of ModusGate installation. 

 

 
 

Figure 13: Internet Service stop during installation 

 
A summary of the installation follows.  If a modification is required, click on the Back button to 
return to previous options. 

 

 
 

Figure 14: ModusGate installation summary 

 
The ModusGate installation starts and services are stopped. 

 

 
 

Figure15: Stopping services 
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Files are being copied to the server. The process displays a graphical progress screen. 

 

 
 

Figure 16: ModusGate installation progress 

 
After installation, at the prompt, click Yes to launch ModusGate services. 

 

 
 

Figure 17: ModusGate services start 

 
As the IIS service was stopped, it needs to be restarted. Click Yes to start IIS. 

 

 
 

Figure 18: Internet services start 

 
The installation procedure has now completed. Click Exit to leave the installation program and 
start with ModusGate configuration. 
 

 
 

Figure 19: ModusGate installation completion 
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3.2. ModusGate route wizard 
 
After installation, the routing wizard is automatically started. It allows configuring incoming 
mail traffic routes in the ModusGate to the Email server. Click Next to start the routing Wizard. 
 
ModusGate can simultaneously filter emails for different domains. As this is a Microsoft Small 
Business Server environment, your Exchange server probably hosts a single domain. If you 
have more than one domain, simply create a route for each domain. Start with your default 
domain, the primary DNS suffix. 
 
Domain names use the format: ‘department.mail.mycompany.com’ or ‘mycompany.com’. Here 
you need to enter the domain name as mentioned at the right of the @ sign in your email 
addresses. For instance, if your local email addresses are user1@mycompany.com, 
user2@mycompany.com... then enter the domain name: ‘mycompany.com’. In this manual 
example we selected the domain name: vircomeurope.com. Enter the domain name. 

 

 
 

Figure 20: Route wizard destination domain 

 
ModusGate needs to transfer legitimate email to the Email server: your Exchange server in 
SBS. Enter the IP address of your Exchange server (the same as your SBS server). 

 

 
 

Figure 21: Route wizard destination server 
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While receiving emails, ModusGate can automatically check if recipients are valid users by 
querying the Active Directory server. This way the ModusGate can automatically create its own 
users list, mirroring the Email server mailbox list, configure user settings, reject messages to 
invalid recipients and allow WebQuarantine access to users with their standard email address 
and password. For maintenance free operation, enable Automatically create mailboxes. 
 

 
 

Figure 22: Route wizard mailbox validation 

 
The next screen allows selecting the Email server type. Microsoft Small Business Server 
includes an Exchange email server. Select Exchange 2000 / 2003. As the Small Business 
Server Active Directory server is the global catalog, modify port 389 in port 3268. Both ports 
actually work, but port 3268 replies much faster. 

 

 
 

Figure 23: Route wizard mailbox validation process 

 
The Routing Wizard now needs details of the ModusGate account you created in Active 
Directory in order to be allowed to read Exchange information. This account can be used for all 
ModusGate filtered domains hosted on your Exchange server. 
 
The ModusGate account data needs to be LDAP formatted. 

- Base DN: DC=sub_domain_name,DC=domain_name,DC:domain_extension 
- User DN: CN:account_name_created_for_modusgate, CN=users, 

DC=sub_domain_name,DC=domain_name,DC:domain_extension 
- Password 

 
WARNING: Be aware that this data is case sensitive. 
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Therefore, in our example without sub domain name, the ModusGate A.D. authentication is: 
- Base DN: DC=vircomeurope,DC=com 
- User DN: CN=modusgate,CN=users,DC=vircomeurope,DC=com 
- Password : xxxxxxxxxx 

 

 
 

Figure 24: Route wizard Active Directory account 

 
A short summary of the created route is displayed. Check if everything is correct, and click the 
Back button to correct anything. Once the route is properly configured, click Next. 
 

 
 

Figure 25: Route Wizard completion 

 
Click Finish to close the Routing wizard, or click Add to add more domains that need to be 
filtered and routed by the ModusGate. The ModusGate installation now completes. The next 
chapter describes how to configure ModusGate to communicate with the Exchange server. 
 
WARNING: If an anti-virus program is running on your SBS server, make sure the following file 
directories are excluded from any desktop virus scan: 

• The modus root directory (e.g. ...\vircom\modusmail or \modusgate) 
• The spool directory 
• The Mailboxes\ @Quarantine directory (or just the @Quarantine directory if it is 

installed in a separate location from the main Mailboxes directory) 

Further anti-virus issues are detailed in the knowledge base article: 

Known Issue: 3rd-Party Anti-Virus Desktop Scanners 
http://www.vircom.com/kbase/default.asp?id=1258&SID=&Lang=1 
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4. Communication between ModusGate & Exchange 
 
Emails are delivered by means of the SMTP protocol, operating by default on port 25. As both 
ModusGate and Exchange use the same default port, it causes a conflict. In order to accept 
incoming email traffic on the SMTP port 25, another port must be to set up for communication 
between the ModusGate and Exchange server, for instance port 26. 
 

4.1. Configuring communication 

4.1.1. Exchange server 
 
Start the Exchange System Manager. Expand Servers, then your server (Jupiter in this 
example) and Protocols. Right click on SMTP Virtual Servers, and click Properties. 
 

 
 

Figure 26: Exchange server SMTP virtual server 
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In this new window General tab, click the Advanced button. 
 
 
 Highlight the line and click Edit. 
 
 

                 
 
  Figure 28: Exchange server SMTP port 

 
 Figure 27: Exchange server SMTP properties  

 
 
You can now see TCP Port 25 is configured. It needs to be modified in port 26 in order to 
communicate with the installed ModusGate software. 
 
 
Modify the TCP port in 26, and click OK. Click OK and Apply to save this new setting. 
 

     
  
 Figure 29: Exchange server SMTP port change Figure 30: Exchange server SMTP port change 
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4.1.2. ModusGate 
 
The ModusGate needs to be configured to communicate with the Exchange server port 26. 
Start the console by double clicking ModusGate Administrator, and click the Connection 
button. 
 
Highlight the IP address under the route you need to modify. Modify you domain route with the 
option Route mail to host or IP address from port 25 to port 26. All domain routes to the 
Exchange server need the option Route mail to host or IP address set to port 26. 
 
Make sure both Automatically populate user list and Authentication request options are 
set to Exchange 2000+, pointing to the SBS server IP address on port 3268 (global catalog) as 
in the example below. 
 
Click Apply. 
 
 

 
 

Figure 31: ModusGate connection with local Active Directory server 

 
 

4.2. Services restart 
 
Both the ModusGate distribution service (SMTPDS) and Microsoft SMTP service need to be 
restarted. 
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4.2.1. ModusGate SMTPDS 
 
Two possibilities: 

• In the ModusGate console, click the System button > Services tab, and highlight 
the SMTPDS (SMTP Delivery Agent). Click Stop and Start. 

• Click Start > Administrative Tools > Services. Right click on modusGate SMTP 

Delivery Agent and click Restart in the menu. 
 

 
 

Figure 32: SMTPDS service restart 

 

4.2.2. Microsoft SMTP service 
 
Click Start > Administrative Tools > Services. Right click on Simple Mail Transfer 

Protocol (SMTP) and click Restart in the menu. 
 

 
 

Figure 33: Microsoft SMTP service restart 
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4.2.3. Microsoft SMTP virtual server 
 
Start the Exchange System Manager. Expand Servers, then your server (Jupiter in this 
example), Protocols > SMTP. 
 

 
 

Figure 34: Microsoft virtual servers 

 
Right click on Default SMTP Virtual Server, click stop. 
Right click on Default SMTP Virtual Server, click start. 

 

 
 

Figure 35: Microsoft SMTP virtual server restart 

 
ModusGate receives incoming SMTP traffic using its own service (SMTPRS) on port 25, and 
transfers messages to the Exchange server on port 26 (Microsoft SMTP service). 
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4.3. Testing communication 
 
If you hadn’t rerouted mail traffic by means of DNS, and emails are still being transmitted to 
your SBS server, the user list in the ModusGate console User button will automatically be 
populated (Press Refresh) with mailboxes receiving messages. Legitimate messages will be 
delivered to the Exchange server while spam, phishing, forbidden attachments and viruses will 
be quarantined. 
 
Test emails can be easily generated with any email client software like Outlook. Create a new 
account with the IP address of your SBS server as SMTP outgoing server. Messages to valid 
mailboxes should be accepted by the ModusGate (end up in Outlook Sent items) while 
messages to invalid mailboxes should be rejected by the ModusGate (transmission error 
keeping such messages in the Outbox) 
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5. Advanced Features, Fine Tuning and Help 
 

5.1. Routing spam to Exchange junk folder 
 
Instead of quarantining, ModusGate can route Spam to MS-Exchange/Outlook “Junk Email” 
folder. Please refer to the following knowledge base article: 
 

How-To: Configure ModusGate with Exchange/Outlook Junk Folder 
http://www.vircom.com/kbase/default.asp?id=1477&SID=&Lang=1 

 
 

5.2. Fine tuning 
 
Default ModusGate settings fit most configurations. However, if you’d like to customize your 
set up, here are a few knowledge base articles that help testing and fine tuning. 
 

How-To: Properly Test the Modus Scan Engine 
http://www.vircom.com/kbase/default.asp?id=1300&SID=&Lang=1 

 
How-To: Effectively Catch Spam and Prevent Unauthorized Relaying 
http://www.vircom.com/kbase/default.asp?id=1339&SID=&Lang=1 

 
Info: Understanding SPF Configuration 
http://www.vircom.com/kbase/default.asp?id=1342&SID=&Lang=1 

 
 

5.3. PDF reader 
 
The F1 key in the ModusGate console opens up the ModusGate administration guide in PDF 
format. 
 
As ModusGate release notes and administration manuals are available in PDF format, it is 
recommended that you install a PDF document reader on the SBS server.  Adobe Acrobat 
Reader is available for download at: http://www.adobe.com/products/acrobat/readstep2.html 
 


